请选择 进入手机版 | 继续访问电脑版
搜索
查看: 427|回复: 3

【原创】分享来自凌特大牛关于LTC6804相关问题解决方案

[复制链接]

12

主题

60

帖子

164

积分

注册会员

Rank: 2

积分
164
发表于 2017-6-14 14:15:30 | 显示全部楼层 |阅读模式
   我从去年5月份来到目前这家公司,当时看到他们仍然用的传统的锂电池管理方案,即用高速光耦作为通道选择,采用MCU的ADC方式采样。而且非常不适合模块话管理,在当今集成芯片的天下,这种方案早就过时了,因此这也是我进来的原因和后面所要做的工作。
    我到新公司的第一天就是选择BMS的管理方案,方案致关重要,一旦选错了,就一错百错,我从TI,MAXIM,ADI,LTC等方案中选择了LTC,当时也经过详细比较,发现虽然LTC成本上不占优势,但它的技术支持,产品质量上确实非其它几家能比的,这样的产品我用起放心,少了很多的售后成本,也是一种节约。我第一次使用LTC产品,还得从LTC6804说起,当时也遇到了不少的问题,现在回想起来还非常感谢帮忙的所有群友。下面我就分享一下我遇到的问题与解决方案。
问题1:LTC6804的IP,IM无法正常通信
原因:其实很多群友都是先把SPI的方式调试通了,再来调试2线通信方式,但我这边电路直接设计成了2线通信方式,所以只能直接调,最后找到原因还是MCU的SPI波特率设置问题,太慢了。
重新设置波特率后,第1步:我先发送1个字节0x55,看波形,在群友的帮助下,我认识了波形先高后低代表‘1’,先低后高代表‘0’,调试好后,我再发送0xAA,果然波形正常了。第2步:调试与6804的通信,我先读配置,在第1步的基本上,顺利读到了6804的配置,心里非常高兴,特别感谢群主。
下面附上截图:

问题2:同样的电路板,老是个别板子出现温度采集错误,5路全错的情况,电压却又很正常,换一张采集板却又正常的现象,也是困扰我很久
原因:这个问题很奇怪,用快速模式ADC转化,这个问题却不容易出现,就是用滤波模式ADC转化时,就容易出现,同样的采集板,换快速模式却又好了。最后在群主的帮忙下,终于找到问题,还是软件上的问题,我把电压与5路温度采集同时进行ADC转化了。由于我们要求采集速度并不高,所以我全部统一采用滤波模式,把电压与温度分开采集,中间间隔500ms,保证转化顺利完成,问题得到彻底解决,再次感谢群主。
下面为正确的代码截图:

在上术问题彻底解决后,作为公司第一代LTC方案的产品正式上市,目前一切正常,非常感谢帮忙过我的群主及群友些,目前我司已经开始使用6811方案,后面还陆续使用5-6串的低成本方案,我们将是LTC的忠实用户,还希望后面继续在群里多多交流,让更多的人使用LTC方案。

问题3:原来采用双路变压器,而且用的其它品牌,菊花连后最多只能达到8张采集板,示波器看后发现波形都严重变形了。
原因:ISOSPI外部电路采用了LTC最可靠,无中心抽变压器双滤波方案,同样所用器件也完全是LTC推荐型号,产品试用后很可靠。
下面附上截图:


分享一些经验希望能帮助大家。




本帖子中包含更多资源

您需要登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

0

主题

16

帖子

18

积分

新手上路

Rank: 1

积分
18
发表于 2017-6-14 20:39:12 | 显示全部楼层
学习使人进步
回复 支持 反对

使用道具 举报

0

主题

16

帖子

18

积分

新手上路

Rank: 1

积分
18
发表于 2017-6-18 10:19:39 | 显示全部楼层
温故而知新
回复 支持 反对

使用道具 举报

2

主题

5

帖子

36

积分

新手上路

Rank: 1

积分
36
发表于 7 天前 | 显示全部楼层
谢谢 分享
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关闭

站长推荐上一条 /1 下一条

Archiver|手机版|小黑屋|凌力尔特技术社区  

GMT+8, 2017-6-26 02:53 , Processed in 0.078251 second(s), 12 queries , Memcache On.

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表